home *** CD-ROM | disk | FTP | other *** search
/ MACD 5 / MACD 5.bin / workbench / wb / czesc_1 / copperprefs / copr.spec < prev    next >
Text File  |  1992-11-22  |  1KB  |  50 lines

  1. FORM COPR
  2. =========
  3.  
  4. Type specification
  5. ==================
  6. The new iff-form "COPR" is currently used by CopperPrefs only.
  7. To give you the possibility to manipulate it or use it in your programs
  8. I will describe in this article the "COPR"-form.
  9.  
  10. Please use the iffparse.library to manipulate files of the COPR-form
  11. and always keep in mind that I'll enhance this format, i.e. I'll
  12. make some chunks longer or I'll add new chunks.
  13.  
  14. The current length and amount of WAIT & MOVE-Chunks slows down read &
  15. write-operations.
  16.  
  17. Chunks
  18. ======
  19.  
  20. 0    LONG    "FORM"
  21. 4    LONG    (Size Of File)-8
  22. 8    LONG    "COPR"
  23.  
  24. COPI
  25. ----
  26. Copper-Info. Read this to find out about the rest of this file.
  27.  
  28. 0    LONG    "COPI"
  29. 4    LONG    (Size Of Chunk In Bytes)
  30. 8    LONG    Number of instructions
  31.  
  32. WAIT
  33. ----
  34. This chunk contains only _ONE_ wait instruction.
  35.  
  36. 0    LONG    "WAIT"
  37. 4    LONG    (Size Of Chunk In Bytes, usually 8)
  38. 8    LONG    Vertical Beam Pos to wait for
  39. 12    LONG    Horizontal Beam Pos to wait for
  40.  
  41.  
  42. MOVE
  43. ----
  44. This chunk contains only _ONE_ move instruction.
  45.  
  46. 0    LONG    "MOVE"
  47. 4    LONG    (Size Of Chunk In Bytes, usually 8)
  48. 8    LONG    Number of color to change (not the address of the register!)
  49. 12    LONG    RGB-Value to load
  50.